解决使用yum安装或升级时出现Error:rpmdb open failed

  • 解决使用yum安装或升级时出现Error:rpmdb open failed已关闭评论
  • 11 views
  • A+
所属分类:VPS新手教程

前几天腾讯云发信息说是有漏洞,需要升级一下OpenSSL,于是乎登入VPS,执行了一下yum update openssl。然后,一堆错误提示就出现了。错误的最后一句是Error:rpmdb open failed。网上查询了一下,两条命令解决了这个问题。这里记录一下,万一以后再遇到,不用抓瞎了。

rm -f /var/lib/rpm/__db*

rpm --rebuilddb

执行完以上命令后,就可以正常的执行yum命令了。

头像