搬瓦工VPS安装LNMP失败的解决方法

  • A+
所属分类:VPS新手教程

有些朋友入手VPS的目的就是搭建一个属于自己的网站,而要搭建网站,就得首先安装网站环境,像是比较常见的LNMP、LAMP、宝塔、等等等等,还有一些收费的这里就不列举了。我个人是比较喜欢LNMP。但是,安装网站环境的时候,总难免会遇到一些问题导致安装失败,所以这篇文章就讲讲,安装LNMP失败的解决方法。

LNMP作为一个比较流行的web生产环境,一键脚本也比较多。我常用的是军哥的LNMP(lnmp.org)这篇文章讲到的也就是军哥的LNMP。

当LNMP安装失败的时候,首先检查以下几个问题。

1、VPS内存过小。

如果你安装MySQL 5.6或5.7及MariaDB 10的话,VPS必须1G以上内存,更高版本至少要2G内存!。安装PHP 7及以上版本必须1G以上内存。

2、VPS系统太新或者太老。

CentOS 5,Debian 6及之前版本其官网已经结束支持无法使用。

PHP 7.1.*以下版本不支持Ubuntu 19+、Debian 10等等非常新的Linux发行版。

PHP 7.4升级或安装必须CentOS 8+,Debian 8+,Ubuntu 16.04+且必须使用1.7。

MySQL 8.0升级或安装必须CentOS 8+,Debian 9+,Ubuntu 16.04+且必须使用1.7。

3、LNMP版本问题。

Ubuntu 18+,Debian 9+,Mint 19+,Deepin 15.7+及所有新的Linux发行版只能使用LNMP1.6及以上的版本进行安装。

有些朋友安装LNMP的时候可能并不是直接去官方的网站复制的最新的命令,而是搜索到的一些以前的旧文章教程,里面的LNMP版本过低的话,加上VPS系统比较新,就容易导致安装失败。

所以大家在安装LNMP的时候,注意看一下安装命令里的数字,lnmp1.5/lnmp1.6这一类的,或者直接去官方网址复制最新的安装命令。

4、上传日志到官方论坛解决。

如果你自己并不能判断或解决问题,可以把VPS的/root目录下的lnmp-install.log,发到LNMP的交流论坛,会不定期的回复解决。

注意,上传日志之前请仔细阅读官方的反馈必读:https://bbs.vpser.net/thread-2555-1-1.html

 

以上就是今天的内容,希望对新手朋友有所帮助,也希望各路大神交流指正。

 

头像

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: